[Mayan EDMS: 2560] Server error during login in mayan edms 3.0

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Mayan EDMS: 2560] Server error during login in mayan edms 3.0

mohd joun
Hi,
I ran mayan-edms-postgres and mayan-edms 3.0 containers..
I was able to get login page properly but after submitting the given credentials . I got server error page.
Here is the traceback from logs

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/django/core/handlers/base.py", line 215, in _get_response
    response = response.render()
  File "/usr/local/lib/python2.7/dist-packages/django/template/response.py", line 107, in render
    self.content = self.rendered_content
  File "/usr/local/lib/python2.7/dist-packages/django/template/response.py", line 84, in rendered_content
    content = template.render(context, self._request)
  File "/usr/local/lib/python2.7/dist-packages/django/template/backends/django.py", line 66, in render
    return self.template.render(context)
  File "/usr/local/lib/python2.7/dist-packages/django/template/base.py", line 207, in render
    return self._render(context)
  File "/usr/local/lib/python2.7/dist-packages/django/template/base.py", line 199, in _render
    return self.nodelist.render(context)
  File "/usr/local/lib/python2.7/dist-packages/django/template/base.py", line 990, in render
    bit = node.render_annotated(context)
  File "/usr/local/lib/python2.7/dist-packages/django/template/base.py", line 957, in render_annotated
    return self.render(context)
  File "/usr/local/lib/python2.7/dist-packages/django/template/defaulttags.py", line 411, in render
    return strip_spaces_between_tags(self.nodelist.render(context).strip())
  File "/usr/local/lib/python2.7/dist-packages/django/template/base.py", line 990, in render
    bit = node.render_annotated(context)
  File "/usr/local/lib/python2.7/dist-packages/django/template/base.py", line 957, in render_annotated
    return self.render(context)
  File "/usr/local/lib/python2.7/dist-packages/compressor/templatetags/compress.py", line 131, in render
    return self.render_compressed(context, self.kind, self.mode, forced=forced)
  File "/usr/local/lib/python2.7/dist-packages/compressor/templatetags/compress.py", line 95, in render_compressed
    return self.get_original_content(context)
  File "/usr/local/lib/python2.7/dist-packages/compressor/templatetags/compress.py", line 123, in get_original_content
    return self.nodelist.render(context)
  File "/usr/local/lib/python2.7/dist-packages/django/template/base.py", line 990, in render
    bit = node.render_annotated(context)
  File "/usr/local/lib/python2.7/dist-packages/django/template/base.py", line 957, in render_annotated
    return self.render(context)
  File "/usr/local/lib/python2.7/dist-packages/django/templatetags/static.py", line 105, in render
    url = self.url(context)
  File "/usr/local/lib/python2.7/dist-packages/django/templatetags/static.py", line 102, in url
    return self.handle_simple(path)
  File "/usr/local/lib/python2.7/dist-packages/django/templatetags/static.py", line 117, in handle_simple
    return staticfiles_storage.url(path)
  File "/usr/local/lib/python2.7/dist-packages/django/contrib/staticfiles/storage.py", line 162, in url
    return self._url(self.stored_name, name, force)
  File "/usr/local/lib/python2.7/dist-packages/django/contrib/staticfiles/storage.py", line 141, in _url
    hashed_name = hashed_name_func(*args)
  File "/usr/local/lib/python2.7/dist-packages/django/contrib/staticfiles/storage.py", line 432, in stored_name
    raise ValueError("Missing staticfiles manifest entry for '%s'" % clean_name)
ValueError: Missing staticfiles manifest entry for 'sources/node_modules/dropzone/dist/dropzone.js'

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

[Mayan EDMS: 2561] Re: Server error during login in mayan edms 3.0

Davide L.
Same problem here, installed both through the trydocker for demo, didn't work, so installed in local. Any kind of installation results in server error when logging in for the first time (Standalone too). 

Where are the logs for checking?  

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

[Mayan EDMS: 2564] Re: Server error during login in mayan edms 3.0

rosarior
Administrator
Issue at GitLab: https://gitlab.com/mayan-edms/mayan-edms/issues/486

The root of the problem seem to be a the third party library used for static media serving (https://github.com/evansd/whitenoise). We are investigating the issue.

On Saturday, July 7, 2018 at 9:09:59 AM UTC-4, Davide L. wrote:
Same problem here, installed both through the trydocker for demo, didn't work, so installed in local. Any kind of installation results in server error when logging in for the first time (Standalone too). 

Where are the logs for checking?  

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

[Mayan EDMS: 2565] Re: Server error during login in mayan edms 3.0

rosarior
Administrator
Fix committed. Scheduled for version 3.0.1 in the next hours.

On Sunday, July 8, 2018 at 12:44:49 AM UTC-4, Roberto Rosario wrote:
Issue at GitLab: <a href="https://gitlab.com/mayan-edms/mayan-edms/issues/486" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgitlab.com%2Fmayan-edms%2Fmayan-edms%2Fissues%2F486\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFWBfOzDT0N0BKm7BVO3ENGYDeVqQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgitlab.com%2Fmayan-edms%2Fmayan-edms%2Fissues%2F486\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFWBfOzDT0N0BKm7BVO3ENGYDeVqQ&#39;;return true;">https://gitlab.com/mayan-edms/mayan-edms/issues/486

The root of the problem seem to be a the third party library used for static media serving (<a href="https://github.com/evansd/whitenoise" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fevansd%2Fwhitenoise\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG5xmh0mG0nm5FDS2RYmwVVRmhnrw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fevansd%2Fwhitenoise\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG5xmh0mG0nm5FDS2RYmwVVRmhnrw&#39;;return true;">https://github.com/evansd/whitenoise). We are investigating the issue.

On Saturday, July 7, 2018 at 9:09:59 AM UTC-4, Davide L. wrote:
Same problem here, installed both through the trydocker for demo, didn't work, so installed in local. Any kind of installation results in server error when logging in for the first time (Standalone too). 

Where are the logs for checking?  

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

[Mayan EDMS: 2566] Re: Server error during login in mayan edms 3.0

rosarior
Administrator
Version 3.0.1 is available on docker hub and PyPI. The problem was caused by a faulty dropzone.js version 5.5.0 NPM package. Mayan now pins all javascript libraries to an exact version (like it does its Python libraries) to avoid this from happening again in the future.

The Play with Docker demo is now running correctly again.

On Sunday, July 8, 2018 at 2:14:30 AM UTC-4, Roberto Rosario wrote:
Fix committed. Scheduled for version 3.0.1 in the next hours.

On Sunday, July 8, 2018 at 12:44:49 AM UTC-4, Roberto Rosario wrote:
Issue at GitLab: <a href="https://gitlab.com/mayan-edms/mayan-edms/issues/486" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgitlab.com%2Fmayan-edms%2Fmayan-edms%2Fissues%2F486\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFWBfOzDT0N0BKm7BVO3ENGYDeVqQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgitlab.com%2Fmayan-edms%2Fmayan-edms%2Fissues%2F486\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFWBfOzDT0N0BKm7BVO3ENGYDeVqQ&#39;;return true;">https://gitlab.com/mayan-edms/mayan-edms/issues/486

The root of the problem seem to be a the third party library used for static media serving (<a href="https://github.com/evansd/whitenoise" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fevansd%2Fwhitenoise\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG5xmh0mG0nm5FDS2RYmwVVRmhnrw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fevansd%2Fwhitenoise\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNG5xmh0mG0nm5FDS2RYmwVVRmhnrw&#39;;return true;">https://github.com/evansd/whitenoise). We are investigating the issue.

On Saturday, July 7, 2018 at 9:09:59 AM UTC-4, Davide L. wrote:
Same problem here, installed both through the trydocker for demo, didn't work, so installed in local. Any kind of installation results in server error when logging in for the first time (Standalone too). 

Where are the logs for checking?  

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [Mayan EDMS: 2571] Re: Server error during login in mayan edms 3.0

mohd joun
Yeah, It worked. Thanks for resolving it quickly.


On Sun, Jul 8, 2018 at 2:04 PM, Roberto Rosario <[hidden email]> wrote:
Version 3.0.1 is available on docker hub and PyPI. The problem was caused by a faulty dropzone.js version 5.5.0 NPM package. Mayan now pins all javascript libraries to an exact version (like it does its Python libraries) to avoid this from happening again in the future.

The Play with Docker demo is now running correctly again.


On Sunday, July 8, 2018 at 2:14:30 AM UTC-4, Roberto Rosario wrote:
Fix committed. Scheduled for version 3.0.1 in the next hours.

On Sunday, July 8, 2018 at 12:44:49 AM UTC-4, Roberto Rosario wrote:
Issue at GitLab: https://gitlab.com/mayan-edms/mayan-edms/issues/486

The root of the problem seem to be a the third party library used for static media serving (https://github.com/evansd/whitenoise). We are investigating the issue.

On Saturday, July 7, 2018 at 9:09:59 AM UTC-4, Davide L. wrote:
Same problem here, installed both through the trydocker for demo, didn't work, so installed in local. Any kind of installation results in server error when logging in for the first time (Standalone too). 

Where are the logs for checking?  

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.