[Mayan EDMS: 2085] empty continuation lines in EDMS Dockerfile, is it an issue?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Mayan EDMS: 2085] empty continuation lines in EDMS Dockerfile, is it an issue?

Lin Pro
Hello,
An error gets spit out while building EDMS from Dockerfile version 2.7.2-2
But the image seems to have been built successfully. Should anything be corrected in that file, though?

Regards
Lin


 
Removing intermediate container 902f3815a574
[WARNING]: Empty continuation line found in:
    RUN apt-get update && apt-get -o Dpkg::Options::="--force-confnew" dist-upgrade -y && apt-get install -y --no-install-recommends         curl         gcc         gettext-base         ghostscript         gpgv         graphviz         libjpeg-dev         libmagic1         libmysqlclient-dev         libpng-dev         libpq-dev         libreoffice         libtiff-dev         locales         nginx         netcat-openbsd         poppler-utils         python-dev         python-pip         python-setuptools         python-wheel         redis-server         supervisor         tesseract-ocr && apt-get clean autoclean && apt-get autoremove --purge -y && rm -rf /var/lib/apt/lists/* && rm -f /var/cache/apt/archives/*.deb
[WARNING]: Empty continuation lines will become errors in a future release.

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

[Mayan EDMS: 2092] Re: empty continuation lines in EDMS Dockerfile, is it an issue?

rosarior
Administrator
Seems to be a warning about something that will change in the future and will produce an error instead then. The empty lines in the Dockerfile are only there for visual clarity and can be removed in the future to silence the warning. Issue added to track this: https://gitlab.com/mayan-edms/mayan-edms-docker/issues/15

On Thursday, September 7, 2017 at 4:26:17 PM UTC-4, Lin Pro wrote:
Hello,
An error gets spit out while building EDMS from Dockerfile version 2.7.2-2
But the image seems to have been built successfully. Should anything be corrected in that file, though?

Regards
Lin


 
Removing intermediate container 902f3815a574
[WARNING]: Empty continuation line found in:
    RUN apt-get update && apt-get -o Dpkg::Options::="--force-confnew" dist-upgrade -y && apt-get install -y --no-install-recommends         curl         gcc         gettext-base         ghostscript         gpgv         graphviz         libjpeg-dev         libmagic1         libmysqlclient-dev         libpng-dev         libpq-dev         libreoffice         libtiff-dev         locales         nginx         netcat-openbsd         poppler-utils         python-dev         python-pip         python-setuptools         python-wheel         redis-server         supervisor         tesseract-ocr && apt-get clean autoclean && apt-get autoremove --purge -y && rm -rf /var/lib/apt/lists/* && rm -f /var/cache/apt/archives/*.deb
[WARNING]: Empty continuation lines will become errors in a future release.

--

---
You received this message because you are subscribed to the Google Groups "Mayan EDMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.