[Mayan EDMS: 188] Error when uploading .doc

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Mayan EDMS: 188] Error when uploading .doc

tilmann.sittig@web.de
Hello all,

i just installed mayan edms from git for evaluation and succeeded so
far. But when i upload a .doc-File i get an error:

[...]
Django Version: 1.3.1
Exception Type: IOError
Exception Value:

[Errno 2] No such file or directory: u'/tmp/
tmpajIfgP_office_converter'

Exception Location: /usr/local/pythonenv/mayan/mayan/apps/converter/
backends/python/base.py in get_page_count, line 28

[...]

I looked through the docs, this group and googled it ... to no
avail ...
All settings are default, all folder-permission seem to be o.k.
( green ) ... any suggestions?

Greeting

till
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mayan EDMS: 189] Error when uploading .doc

rosarior
Administrator
Thanks for reporting.  The office document conversion subsystem is complex and problem prone because LibreOffice and OpenOffice do not provide a way to convert documents via library calls or a specialized utility.  Some questions to help me recreate your setup:  Did you install unoconv?  What version you used (the one from your distribution or the one on github)?  Is this error appearing on the web interface or in the console/log file?  Is LibreOffice installed?  What version?  Are you getting this error running Mayan via a web server or via Django debug server?  Thanks


On Sat, May 19, 2012 at 4:25 AM, [hidden email] <[hidden email]> wrote:
Hello all,

i just installed mayan edms from git for evaluation and succeeded so
far. But when i upload a .doc-File i get an error:

[...]
Django Version: 1.3.1
Exception Type: IOError
Exception Value:

[Errno 2] No such file or directory: u'/tmp/
tmpajIfgP_office_converter'

Exception Location:     /usr/local/pythonenv/mayan/mayan/apps/converter/
backends/python/base.py in get_page_count, line 28

[...]

I looked through the docs, this group and googled it ... to no
avail ...
All settings are default, all folder-permission seem to be o.k.
( green ) ... any suggestions?

Greeting

till

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mayan EDMS: 191] Error when uploading .doc

tilmann.sittig@web.de


Hello Roberto,

thanks for your reply, here are my installation-details as requested:

a) unoconv is installed, from default ubuntu-server distro repository ( kernel 2.6.32-41-server ) in version :

unoconv 0.3
[...]
platform posix/linux2
python 2.6.5 (r265:79063, Apr 16 2010, 13:57:41)
[GCC 4.4.3]

build revision $Rev$

b) The error appears in the webinterface - i have activated debug in setting.py

c) LibreOffice is not installed, only openoffice - i think it got installed during mayan install procedure because the machine is a server without gnome - and only openoffice.org-core and -common are installed in deb-version 1:3.2.0-7u

d) Mayan EDMS is the only python-app running in an updated Apache2 Server using mod_wsgi

Hope that helps, please let me know if you need more information.

Greetings

till


Am Montag, 21. Mai 2012 07:35:22 UTC+2 schrieb Roberto Rosario:
Thanks for reporting.  The office document conversion subsystem is complex and problem prone because LibreOffice and OpenOffice do not provide a way to convert documents via library calls or a specialized utility.  Some questions to help me recreate your setup:  Did you install unoconv?  What version you used (the one from your distribution or the one on github)?  Is this error appearing on the web interface or in the console/log file?  Is LibreOffice installed?  What version?  Are you getting this error running Mayan via a web server or via Django debug server?  Thanks

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mayan EDMS: 191] Error when uploading .doc

rosarior
Administrator

Awesome, thanks for the info, I will start trying to recreate your conditions to trigger the bug.  Thanks,
Roberto

On May 22, 2012 2:50 PM, "[hidden email]" <[hidden email]> wrote:


Hello Roberto,

thanks for your reply, here are my installation-details as requested:

a) unoconv is installed, from default ubuntu-server distro repository ( kernel 2.6.32-41-server ) in version :

unoconv 0.3
[...]
platform posix/linux2
python 2.6.5 (r265:79063, Apr 16 2010, 13:57:41)
[GCC 4.4.3]

build revision $Rev$

b) The error appears in the webinterface - i have activated debug in setting.py

c) LibreOffice is not installed, only openoffice - i think it got installed during mayan install procedure because the machine is a server without gnome - and only openoffice.org-core and -common are installed in deb-version 1:3.2.0-7u

d) Mayan EDMS is the only python-app running in an updated Apache2 Server using mod_wsgi

Hope that helps, please let me know if you need more information.

Greetings

till


Am Montag, 21. Mai 2012 07:35:22 UTC+2 schrieb Roberto Rosario:
Thanks for reporting.  The office document conversion subsystem is complex and problem prone because LibreOffice and OpenOffice do not provide a way to convert documents via library calls or a specialized utility.  Some questions to help me recreate your setup:  Did you install unoconv?  What version you used (the one from your distribution or the one on github)?  Is this error appearing on the web interface or in the console/log file?  Is LibreOffice installed?  What version?  Are you getting this error running Mayan via a web server or via Django debug server?  Thanks

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mayan EDMS: 195] Error when uploading .doc

rosarior
Administrator
In reply to this post by tilmann.sittig@web.de
Registered on github's issue tracker as issue 25 (https://github.com/rosarior/mayan/issues/25)

On Tuesday, May 22, 2012 2:50:22 PM UTC-4, [hidden email] wrote:


Hello Roberto,

thanks for your reply, here are my installation-details as requested:

a) unoconv is installed, from default ubuntu-server distro repository ( kernel 2.6.32-41-server ) in version :

unoconv 0.3
[...]
platform posix/linux2
python 2.6.5 (r265:79063, Apr 16 2010, 13:57:41)
[GCC 4.4.3]

build revision $Rev$

b) The error appears in the webinterface - i have activated debug in setting.py

c) LibreOffice is not installed, only openoffice - i think it got installed during mayan install procedure because the machine is a server without gnome - and only openoffice.org-core and -common are installed in deb-version 1:3.2.0-7u

d) Mayan EDMS is the only python-app running in an updated Apache2 Server using mod_wsgi

Hope that helps, please let me know if you need more information.

Greetings

till


Am Montag, 21. Mai 2012 07:35:22 UTC+2 schrieb Roberto Rosario:
Thanks for reporting.  The office document conversion subsystem is complex and problem prone because LibreOffice and OpenOffice do not provide a way to convert documents via library calls or a specialized utility.  Some questions to help me recreate your setup:  Did you install unoconv?  What version you used (the one from your distribution or the one on github)?  Is this error appearing on the web interface or in the console/log file?  Is LibreOffice installed?  What version?  Are you getting this error running Mayan via a web server or via Django debug server?  Thanks

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Mayan EDMS: 197] Error when uploading .doc

rosarior
Administrator
New office document converter backend  https://github.com/rosarior/mayan/commit/d235ca406f83464df48293ef8dca184068dbe269
Should be out for maintenance version 0.12.1 soon.

https://github.com/rosarior/mayan/issues/25#issuecomment-5978101


On Thursday, May 24, 2012 2:09:08 AM UTC-4, Roberto Rosario wrote:
Registered on github's issue tracker as issue 25 (https://github.com/rosarior/mayan/issues/25)

On Tuesday, May 22, 2012 2:50:22 PM UTC-4, [hidden email] wrote:


Hello Roberto,

thanks for your reply, here are my installation-details as requested:

a) unoconv is installed, from default ubuntu-server distro repository ( kernel 2.6.32-41-server ) in version :

unoconv 0.3
[...]
platform posix/linux2
python 2.6.5 (r265:79063, Apr 16 2010, 13:57:41)
[GCC 4.4.3]

build revision $Rev$

b) The error appears in the webinterface - i have activated debug in setting.py

c) LibreOffice is not installed, only openoffice - i think it got installed during mayan install procedure because the machine is a server without gnome - and only openoffice.org-core and -common are installed in deb-version 1:3.2.0-7u

d) Mayan EDMS is the only python-app running in an updated Apache2 Server using mod_wsgi

Hope that helps, please let me know if you need more information.

Greetings

till


Am Montag, 21. Mai 2012 07:35:22 UTC+2 schrieb Roberto Rosario:
Thanks for reporting.  The office document conversion subsystem is complex and problem prone because LibreOffice and OpenOffice do not provide a way to convert documents via library calls or a specialized utility.  Some questions to help me recreate your setup:  Did you install unoconv?  What version you used (the one from your distribution or the one on github)?  Is this error appearing on the web interface or in the console/log file?  Is LibreOffice installed?  What version?  Are you getting this error running Mayan via a web server or via Django debug server?  Thanks

Loading...